CVE Vulnerabilities

CVE-2022-26562

Improper Authentication

Published: Apr 01, 2022 | Modified: May 11, 2023
CVSS 3.x
9.8
CRITICAL
Source:
NVD
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu
MEDIUM

An issue in provider/libserver/ECKrbAuth.cpp of Kopano Core <= v11.0.2.51 contains an issue which allows attackers to authenticate even if the user account or password is expired. It also exists in the predecessor Zarafa Collaboration Platform (ZCP) in provider/libserver/ECPamAuth.cpp of Zarafa >= 6.30 (introduced between 6.30.0 RC1e and 6.30.8 final).

Weakness

When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.

Affected Software

Name Vendor Start Version End Version
Groupware_core Kopano 11.0.2.51 (including) 11.0.2.51 (including)
Kopanocore Ubuntu bionic *
Kopanocore Ubuntu impish *
Kopanocore Ubuntu kinetic *
Kopanocore Ubuntu trusty *
Kopanocore Ubuntu xenial *

Potential Mitigations

References