CVE Vulnerabilities

CVE-2024-0200

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection')

Published: Jan 16, 2024 | Modified: Jan 23, 2024
CVSS 3.x
9.8
CRITICAL
Source:
NVD
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.x
RedHat/V2
RedHat/V3
Ubuntu

An unsafe reflection vulnerability was identified in GitHub Enterprise Server that could lead to reflection injection. This vulnerability could lead to the execution of user-controlled methods and remote code execution. To exploit this bug, an actor would need to be logged into an account on the GHES instance with the organization owner role. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.12 and was fixed in versions 3.8.13, 3.9.8, 3.10.5, and 3.11.3. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness

The product uses external input with reflection to select which classes or code to use, but it does not sufficiently prevent the input from selecting improper classes or code.

Affected Software

Name Vendor Start Version End Version
Enterprise_server Github 3.8.0 *
Enterprise_server Github 3.9.0 *
Enterprise_server Github 3.10.0 *
Enterprise_server Github 3.11.0 *

Potential Mitigations

References