CVE Vulnerabilities

CVE-2024-20926

Published: Jan 16, 2024 | Modified: Feb 01, 2024
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
RedHat/V2
RedHat/V3
Ubuntu

Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Scripting). Supported versions that are affected are Oracle Java SE: 8u391, 8u391-perf, 11.0.21; Oracle GraalVM for JDK: 17.0.9; Oracle GraalVM Enterprise Edition: 20.3.12, 21.3.8 and 22.3.4. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition. Successful attacks of this vulnerability can result in unauthorized access to critical data or complete access to all Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability can be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. This vulnerability also applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. CVSS 3.1 Base Score 5.9 (Confidentiality impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N).

Affected Software

Name Vendor Start Version End Version
Graalvm Oracle 20.3.12 20.3.12
Graalvm Oracle 21.3.8 21.3.8
Graalvm Oracle 22.3.4 22.3.4
Graalvm_for_jdk Oracle 17.0.9 17.0.9
Graalvm_for_jdk Oracle 21.0.1 21.0.1
Jdk Oracle 1.8.0 1.8.0
Jdk Oracle 1.8.0 1.8.0
Jdk Oracle 11.0.21 11.0.21
Jdk Oracle 17.0.9 17.0.9
Jdk Oracle 21.0.1 21.0.1
Jre Oracle 1.8.0 1.8.0
Jre Oracle 1.8.0 1.8.0
Jre Oracle 11.0.21 11.0.21
Jre Oracle 17.0.9 17.0.9
Jre Oracle 21.0.1 21.0.1

References