CVE Vulnerabilities

CVE-2025-2175

Published: Mar 11, 2025 | Modified: Jun 17, 2026
CVSS 3.x
6.5
MEDIUM
Source:
NVD
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.x
RedHat/V2
RedHat/V3
Ubuntu
MEDIUM

A vulnerability was found in libzvbi up to 0.2.43. It has been rated as problematic. Affected by this issue is the function _vbi_strndup_iconv. The manipulation leads to integer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

Affected Software

NameVendorStart VersionEnd Version
ZvbiZapping-vbi*0.2.44 (excluding)
ZvbiUbuntuesm-apps-legacy/xenial*
ZvbiUbuntuesm-apps/bionic*
ZvbiUbuntuesm-apps/focal*
ZvbiUbuntuesm-apps/jammy*
ZvbiUbuntuesm-apps/noble*
ZvbiUbuntuesm-apps/xenial*
ZvbiUbuntufocal*
ZvbiUbuntujammy*
ZvbiUbuntunoble*
ZvbiUbuntuoracular*
ZvbiUbuntuupstream*

References