CVE Vulnerabilities

CVE-2021-23840

This vulnerability is marked as RESERVED by NVD. This means that the CVE-ID is reserved for future use by the CVE Numbering Authority (CNA) or a security researcher, but the details of it are not yet publicly available yet.

This page will reflect the classification results once they are available through NVD.

Any vendor information available is shown as below.

Redhat

CVE-2021-23840 openssl: integer overflow in CipherUpdate

Affected Software List

NameVendorVersion
Red Hat Advanced Cluster Management for Kubernetes 2.2 for RHEL 7RedHatrhacm2/thanos-rhel7:v2.2.2-3
Red Hat Advanced Cluster Management for Kubernetes 2.2 for RHEL 8RedHatrhacm2/work-rhel8:v2.2.2-3
Red Hat Advanced Cluster Management for Kubernetes 2.3 for RHEL 7RedHatrhacm2/management-ingress-rhel7:v2.3.0-36

Ubuntu

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Affected Software List

NameVendorVersion
Edk2Ubuntu/trustyout of standard support
NodejsUbuntu/trustyout of standard support
NodejsUbuntu/upstreamTBD
OpensslUbuntu/devel1.1.1j-1ubuntu1
OpensslUbuntu/focal1.1.1f-1ubuntu2.2
OpensslUbuntu/groovy1.1.1f-1ubuntu4.2
OpensslUbuntu/hirsute1.1.1j-1ubuntu1
OpensslUbuntu/trustyout of standard support
OpensslUbuntu/bionic1.1.1-1ubuntu2.1~18.04.8
OpensslUbuntu/esm-infra/xenial1.0.2g-1ubuntu4.19
OpensslUbuntu/precise/esmend of ESM support, was needs-triage
OpensslUbuntu/trusty/esmTBD
OpensslUbuntu/upstream1.1.1j
OpensslUbuntu/xenial1.0.2g-1ubuntu4.19
Openssl1.0Ubuntu/upstream1.0.2y
Openssl1.0Ubuntu/bionic1.0.2n-1ubuntu5.6