CVE Vulnerabilities

CVE-2021-3517

This vulnerability is marked as RESERVED by NVD. This means that the CVE-ID is reserved for future use by the CVE Numbering Authority (CNA) or a security researcher, but the details of it are not yet publicly available yet.

This page will reflect the classification results once they are available through NVD.

Any vendor information available is shown as below.

Redhat

CVE-2021-3517 libxml2: Heap-based buffer overflow in xmlEncodeEntitiesInternal() in entities.c

Affected Software List

NameVendorVersion
Red Hat Enterprise Linux 8RedHatlibxml2-0:2.9.7-9.el8_4.2
Red Hat Migration Toolkit for Containers 1.4RedHatrhmtc/openshift-migration-ui-rhel8:v1.4.6-4

Ubuntu

There is a flaw in the xml entity encoding functionality of libxml2 in versions before 2.9.11. An attacker who is able to supply a crafted file to be processed by an application linked with the affected functionality of libxml2 could trigger an out-of-bounds read. The most likely impact of this flaw is to application availability, with some potential impact to confidentiality and integrity if an attacker is able to use memory information to further exploit the application.

Affected Software List

NameVendorVersion
Libxml2Ubuntu/esm-infra/xenial2.9.3+dfsg1-1ubuntu0.7+esm1
Libxml2Ubuntu/trusty/esm2.9.1+dfsg1-3ubuntu4.13+esm2
Libxml2Ubuntu/xenialend of standard support, was needs-triage
Libxml2Ubuntu/bionic2.9.4+dfsg1-6.1ubuntu1.4
Libxml2Ubuntu/focal2.9.10+dfsg-5ubuntu0.20.04.1
Libxml2Ubuntu/groovy2.9.10+dfsg-5ubuntu0.20.10.2
Libxml2Ubuntu/hirsute2.9.10+dfsg-6.3ubuntu0.1
Libxml2Ubuntu/precise/esmend of ESM support, was needs-triage
Libxml2Ubuntu/trustyout of standard support
Libxml2Ubuntu/upstream2.9.10+dfsg-6.6